Jump to content

SKR 2 SD Card/Firmware Issue


Recommended Posts

So i've been trying to flash a firmware.bin with the sd card, but it seems that the board refuses to read the sd card, is there anything i can do, this is a brand new board(literally like 2 days old), the LCD also says printer disconnected for some reason

The board is a Bigtreetech SKR 2, the LCD is a Bigtreetech TFT35 v3.0, i'm using Bigtreetech Stepstick Mute TMC2208 V3.08 drivers and a stock ender 5 plus power supply.

The SD Card i'm using is a netac 8gb microsd card, i've tried using pre-compiled firmwares and i've tried compiling my own, nothing works, if the board is defective, how do i go about getting a replacement, i
live in south africa so obviously shipping is quite expensive.

I also emailed support but it seems that this is probably a better and easier way to get help

Another noteworthy mention is that if i insert the sd card, power cycle, the firmware does not turn from firmware.bin to firmware.cur like everyone says it should, the board is working as i can connect to it with octoprint, if theres another way to flash it maybe with my pi/arduino i'd be down to try something like that too

Link to comment
Share on other sites

Hi,

1. First format the SD card and select FAT32 as the file system.
2. Please put two same firmware in SD card. One named "firmware" and one named "firmware.bin".
3. Then re-update the firmware. Check to see if any of the files on the SD card can be capitalized. Because some win10 systems hide the .bin suffix by default. It maybe mater to your firmware. Please make a test with the attachment firmware.

 

firmware.bin

Link to comment
Share on other sites

Ok so i followed your instructions exactly, still not working, since octoprint works i tried loading a gcode model onto the sd card and that's not even showing up, the sd card works with my stock ender 5 board, so i think the sd card reader on my SK2 has to be broken, i don't see what else it could be since my computer sees it, and the old board see's it too.

No file names changed in any way after looking at the sd card afterwards

 

On octoprint i'm getting SD Init Fail as well whenever i connect to the printer

 

EDIT:

 

Is there nothing i can do perhaps to flash it another way I.E using an arduino or usb or octoprint maybe?

Edited by vgaggia
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...