Jump to content

SKR 3 can't connect via USB


Recommended Posts

this week I got my new SKR 3 board (bought is because my previous SKR 1.3 has gone...) and I cannot connect on it via usb (regardless of the state of the white button)
I built a Marlin firmware what flashed, but still no connection (tried the connection from PC, OctopPi, Laptop)
what could be wrong can somebody help me?

Link to comment
Share on other sites

When the white button is pressed, in my Linux I got "usb 5-1.4-port1: Cannot enable. Maybe the USB cable is bad?" .

When the it not pressed I got nothing.

If I go into the bootloader mode (pressed boot & reset same time), my Linux say this



usb 5-1.4.1: new full-speed USB device number 54 using xhci_hcd
usb 5-1.4.1: not running at top speed; connect to a high speed hub
usb 5-1.4.1: New USB device found, idVendor=0483, idProduct=df11, bcdDevice= 2.00
usb 5-1.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-1.4.1: Product: DFU in FS Mode
usb 5-1.4.1: Manufacturer: STMicroelectronics
usb 5-1.4.1: SerialNumber: 3050353E3231


so I think, the USB hardware and the cable are ok

Link to comment
Share on other sites

For several days I have been looking for a solution to this problem, and the manufacturer dismisses me.
Loaded firmware from reprap for H723 detects the serial port.
You probably have to wait for marlin firmware updates.

The worst thing is that I bought 2 pieces of this motherboard 😞

Edited by kombo
Link to comment
Share on other sites

  • 4 months later...
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...