Jump to content

SKR Mini E3 V3 Firmware won't Update


Recommended Posts

Hello,

I recently purchased the SKR Mini E3 V3 along with the BTT TFT35-E3 V3 display. I installed both units on my Ender 3 Pro last night and everything went fine but could not for the life of me get the SKR firmware to update. I downloaded the precompiled firmware for the BLTouch form BTT's GitHub page, put it on the SD card, renamed it firmware.bin, inserted the SD card in the mainboard SD card slot, and powered up the printer. The first time I tried this I got an error on the screen saying something like "EEPROM size to large" or nothing like that. That only happened the first time. Now when I try updating nothing happens, the printer just powers up like it would normally as if I weren't trying to update the firmware. I also have removed the Z-axis homing switch and install a Creality CR Touch if that has anything to do with this issue. I've tried removing the .bin at the end as well as renaming it FIRMWARE in all caps as some have suggested but none of that worked either. I've made sure to format the SD card in FAT32 before trying to update as well. Has anyone else run into the problem? Are there any fixes for this?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...