Jump to content

EZ31865 with Octopus Max EZ?

Recommended Posts

Has anyone actually managed to get this setup to work? BTT support is useless on this topic and the manual shows outdated pin assignments that are rejected by bugfix 2.1.x.

Both temp sensors are set as -5.

I commented out E4 and E5 pinouts and reassigned to:

#define TEMP_0_MISO_PIN PE13
#define TEMP_0_SCK_PIN PE12
#define TEMP_0_MOSI_PIN PE14
#define TEMP_0_CS_PIN PG8

#define TEMP_1_MISO_PIN PE13
#define TEMP_1_SCK_PIN PE12
#define TEMP_1_MOSI_PIN PE14
#define TEMP_1_CS_PIN PG7


I've uncommented:




I've tried forcing HW SPI and conversely tried forcing SOFTWARE_SPI.


I have 2 EZ31865's plugged into EZ slots for motors 9 and 10. I have 2 PT1000's plugged into the 2 middle pins on the M9 and M10 motor slots.


No matter what I do, the board won't connect. I assume due to a temp error forcing it to shutdown.

If I revert back to temp sensor 1047 for both sensors, it connects fine but only displays 1 temp. The other temp says 0 despite both sensors showing identical resistance. There seem to be no guides or support post anywhere so I'm at a loss here.


Will absolutely venmo anyone who knows of a solution $50 to stop me from ripping out more of my hair.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...