Jump to content

SKR 2 resets USB after about a minute..


Recommended Posts

Hello i have a SKR 2 flashed with the latest Marlin and it works quite well, for about a minute, at which point there seems to be a USB reset as the device - which usually enumerates as /dev/ttyACM0 - has now been re-enumerated as /dev/ttyACM1 thus the software (tried openpnp and pronterface) looses its connection.

Reconnecting to /dev/ttyACM1 works for yet ~1 minute at which point it resets back to /dev/ttyACM0. I've tried different USB cables, different ports and even tried using a USB hub but to no avail.

The interesting thing is that if i connect the USB cable without actually connecting to the serial device it doesn't seem to reset, seemingly the continuous data being sent to the SKR makes it crash at some point.. so, any ideas what this is all about? Busted SKR or could it be something in Marlin?

Thanks

Karl

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...