Jump to content

SKR E3 DIP v1.0 not controlling steppers

Ken Knight

Recommended Posts

Let me apologize in advance for the length of this post.  Just want to make sure you have all the information.  But I'll try and be succinct.

Purchased a SKR E3 DIP v1.0 a few years ago off Amazon for a project and never used it.

A friend has a Tronxy XY-2 that the board went out in so I figured I'd try and replace it with the DIP board.  This tronxy is before they started using ribbon cable so all cables are separate just like an Ender etc.

When I bought the DIP it came with some A4988 drivers, so I put them in with the POT pointing to the left. 

Switched all the jumpers beneath the driver board to the right set of pins as per the picture found in Github on the DIP board.

Copied down the A4988 firmware for the DIP board from the BTT Github and installed it.

Connected the TFT35 E3 to the board and powered on unit.

Everything booted and the TFT connects and identifies the board as the SKR E3 DIP. 

However, when I try to move any of the steppers nothing happens.  I've also connected with Pronterface and issued gcode commands to move but no luck.

Decided to pull down the latest marlin source and configure and compile it following the guide located here

It would not compile due to the code in STM32F103RC_SKR_MINI.py lines 6 thru 10.  So I commented those out and just made the flash 512.  It would then compile properly and that will load on the board fine.  But steppers still don't function.  Tried dropping it back to 256 and also changing the default_env from STM32F103RC_btt_512k_USB to STM32F103RC_btt_USB and still no luck.

I've tried the stepper drivers on another machine that also using 4988s and they work fine.  I also a tried another stepper that I have and it works on the other machine but not when connected to the DIP.


Any thoughts would be greatly appreciated.



PS.  Here's the code I commented out in case it is what is causing my problems:

# for define in env['CPPDEFINES']:
#    if define[0] == "VECT_TAB_ADDR":
#        env['CPPDEFINES'].remove(define)
#    if define[0] == "STM32_FLASH_SIZE":
#        STM32_FLASH_SIZE = define[1]


Link to comment
Share on other sites


So I think I had the stepper drivers plugged in backwards.  The pot looks like it should be on the right.  Once I did that if I go to the move menu and hit the move button you can hear and feel the stepper motor engage, however, it doesn't actually move.  But they are all locked and if I hit the disarm all button I can then move them around manually.

Further suggestions?




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...