Jump to content

any successful Hermit Crab CAN experiences?

Harald Gutsche

Recommended Posts

I bought a Hermit Crab *CAN* tool changer recently.
I got it installed and it *basically* works.

Yesterday, I ordered a H2 V2S lite with that special high flow nozzle that should work with the Hermit Crab CAN.

Searching the web, I didn't find any success stories...neither of the crab CAN version nor in combination with such an extruder, which makes me a bit nervous.

The thing is, my crab has problems with loosing communication (I submitted a support ticket, the first one with complete info seemed to be thrown away when sending [page timeout? frustrating!], so I created a shorter one, and got a thank you, but I wonder if I shouldn't get an email that it was received?).

I tried a lot of variants to narrow down the problem area, e.g.

  • CAN and USB work the same way,
  • 12V and 24V (with reduced max_power) doesn't matter
  • different cables
  • ...

It basically boils down to a 30W limit for the heater, which would not be enough for the HF nozzle that seems to have a 70W heater.
If I limit it's power via  max_power=0.75 (on 12V) the crab draws 30W from the type-c cable (one of them is 100W PD and has a display) and the heat up works.
But then I get the communication lost after some bigger layers were successfully printed (with my usual print parameters, 100mm/s, 0.4mm nozzle, 0,2mm layer height, the extruder is the same as before the crab).
If I use more power, then it looses communication after several seconds. More or less a similar time on each attempt.

I thought, what is common for the heat up of a hotend and printing.
One reason could be the temperature of the board.

So, I tried to use a fan to cool the circuit board.
With a good configuration (enough flow and a good position), I can actually heat up the heater with full 40W power up to 200°C without loosing communication.
But only for the first time, any following attempt fails again after seconds (even after cooling it down again to room temperature).
Which doesn't sound logical to me.

So, for now, it could be a faulty circuit board, some limitations that are not communicated when buying, maybe wrong usage, etc.

I would really like to hear of any success stories for the CAN version.
This would allow, to search in the right direction, e.g. is it only me or is it something general?

Link to comment
Share on other sites

I solved the issue after a lot of debugging...

Before I had used either the type-c cable alone with CAN or the USB port for communication and the type-c cable for power.

After connecting the crab via USB and extra power cable instead of powering via the type-c cable, the power connector immediately burned and melted and the smd component near the biggest condensator lighted up towards the board and also upwards. It really looked like the board would burn. But it was only this component. I measured where it is connected and found a connection to DCIN and to C17, so it is the 5A fuse. The only connected components were a heater and a thermistor. In the last test I used a 40W heater at 24V, which draws less than 2A.

I now removed the fuse and soldered the two pads directly together.

Then it worked...

Using the type-c cable to power also works and shows 37W.

Next, I will test all the other variants I tried before that failed. I guess they all will work.
And then I'll try it in my printer with some bigger print.

I remember a review on amazon, where the reviewer had a similar problem with that fuse. He wrote he had to solder it again.
I doubt that this was the real problem. After the thing lighted up, I also soldered it and tried again, but it showed the same "effect".
I measured the component and it had 0.3 Ohm in both directions. Not sure what value it should have.

Link to comment
Share on other sites


it's still surprising, that cooling the usb-c connector as shown in the picture, solved the issue (at least for the heater test).

I guess the fuse is a PTC reset fuse, then cooling it down probably "resets" it.

I only cooled the connector, but I guess the fuse is then cooled down via the GND connection to the board. Such boards usually have a GND layer, so it's everywhere.

Link to comment
Share on other sites

as a conclusion it seems, that the fuse was about  2.5A (30W/12V) instead of 5A and reacting slowly.
Though why should it start to burn? instead it should only disconnect the power.

Or the soldering wasn't good and started to heat up which then triggered the fuse (if it's the heat that triggers it).

Edited by Harald Gutsche
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...