Jump to content

Z Axis stepper motor runs backwards on my SKR mini E3 V3.0


Recommended Posts

I have installed an SKR mini E3 V3.0 on my Ender 5 and the Z axis stepper motor runs the wrong way. I have double checked all connections and I am fairly sure I have everything hooked up properly. When I command the Z axis to go up it goes down and when commanded to go down it goes up. I have tried various firmware builds and nothing has changed. 

I am running Marlin bugfix-2.0.x (May 28 2022)

My TFT35__E3_V3.0 is running firmware V27.x May 23 2022 in 120Mhz.

Link to comment
Share on other sites

Posted (edited)

Find this section in configuration.h, change as you require (below are how I set it for my anet a8):

// Invert the stepper direction. Change (or reverse the motor connector) if an axis goes the wrong way.
#define INVERT_X_DIR false
#define INVERT_Y_DIR false
#define INVERT_Z_DIR true

 

Edited by Nad42
Link to comment
Share on other sites

Things started working my Ender 5 when I went and put the TFT35 V3.0 back to the download that is on the BTT download page. I reinstalled the CR-Touch and the Z-Axis stepper does not home properly. It moves within about 3 inches of the top then stops. For the heck of it I tried the bed leveling on the TFT35 V3.0 and the system goes through the motions but the hot end never touches the Z axis plate. I have uploaded the Ender 5 BL touch firmware on this website.

Any ideas?

Thanks for the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...