Jump to content

SD init fail


Recommended Posts

Installed the SKR Mini E3 V3.0 to Ender 3 Pro and was previously using a micro SD to SD card extension cable adapter and I now get the "SD init fail" message. I tried using multiple adapters that I use on my other Ender 3 with same message. When I use the basic micro SD card it works properly so it's definitely not my micro SD card slot being damaged. What can cause this error and is there a fix?

 

 

 

 

 

e

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Bump!
I just installed a SKR Mini E3 V3.0 in my Ender 3 and neither of my extension cable card readers work with the printer, now.
The card works fine, I was able to upgrade the firmware with it plugged directly into the board.  But, neither extension cable card reader works. No matter what I do, I get a "SD init fail" with the extension cable card reader.  This is very frustrating because the location on the Ender 3 for the card slot is terrible.  I wouldn't have bought this board had I known this.
Are there any extension cable card readers that work with this board or did @Primo Designs solve this?

Link to comment
Share on other sites

19 hours ago, mattp said:

Bump!
I just installed a SKR Mini E3 V3.0 in my Ender 3 and neither of my extension cable card readers work with the printer, now.
The card works fine, I was able to upgrade the firmware with it plugged directly into the board.  But, neither extension cable card reader works. No matter what I do, I get a "SD init fail" with the extension cable card reader.  This is very frustrating because the location on the Ender 3 for the card slot is terrible.  I wouldn't have bought this board had I known this.
Are there any extension cable card readers that work with this board or did @Primo Designs solve this?

I found this "fix" https://github.com/bigtreetech/BIGTREETECH-SKR-mini-E3/issues/637

I added the NO_SD_DETECT line to my Configuration.h and recompiled and flashed the board. Now I can eject and add the SD card if it's inserted into the card slot on the board.  But, like in the thread above, I can't use an extension cable card reader.  Is this a known defect, or do I have a bad card?

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...