Jump to content

No Printer Attached TFT35 E3


Recommended Posts

I upgraded my CR-10v3 with a SKR Mini E3 v3.0 and a TFT35 E3. Marlin Mode is working fine, but I can't get touchscreen Mode to work. It only says "No Printer Attached".

I tried:

  • Baudrate 250000 and 115200

  • upgrading firmware on both the board and tft

  • serial port as -1 and 2 and serial port 2 as -1 and 1

I can connect to the printer via Printer face after updating my USB drivers and the firmware. What else is there to test?

Any help is appreciated.

Edit: i also checked the Pins with the schematics. Seems to be correct.

Link to comment
Share on other sites

  • 1 month later...

I have an SKR 2 (B version) and a BTT TFT35-E3 V3.0 and am having the exact same issue.  The Marlin Mode works fine, but the TFT Mode says no printer attached.  When I disconnect the two Marlin Mode ribbon cables, the TFT has no power.  I've checked the TFT cable installation, and the reset and 3.3v pins are correctly aligned.  When I supply power through the separate 5v power connector using a separate cable, the TFT lights up, but again the no printer connected message, even though the lack cable is still connected.  I checked the power and ground pins on the RS232 TFT pins on the SKR board and it shows a 3.3v output.  It doesn't appear that the RS232 interface pins are working.  Is there a way to use the UART3 pins as Printer1?  How do I fix this issue?

Link to comment
Share on other sites

  • Administrators
On 6/9/2022 at 11:42 AM, Rethys said:

I have an SKR 2 (B version) and a BTT TFT35-E3 V3.0 and am having the exact same issue.  The Marlin Mode works fine, but the TFT Mode says no printer attached.  When I disconnect the two Marlin Mode ribbon cables, the TFT has no power.  I've checked the TFT cable installation, and the reset and 3.3v pins are correctly aligned.  When I supply power through the separate 5v power connector using a separate cable, the TFT lights up, but again the no printer connected message, even though the lack cable is still connected.  I checked the power and ground pins on the RS232 TFT pins on the SKR board and it shows a 3.3v output.  It doesn't appear that the RS232 interface pins are working.  Is there a way to use the UART3 pins as Printer1?  How do I fix this issue?

If you have any product issues, please submit a request and we will arrange for an engineer to communicate with you as soon as possible.

Click on the top navigation "Submit a request" or Please click
https://support.biqu3d.com/hc/en-us/requests/new

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...