Jump to content

E3EZ serial port not found

Recommended Posts

should have given more detail:

firmware uploads,  3V3 is green, firmware.bin renamed

tried 3 cables, all USB ports

removed, reinstalled klipper on pi

 systemctl status klipper.service

  klipper.service - Klipper 3D Printer Firmware SV1
     Loaded: loaded (/etc/systemd/system/klipper.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2023-03-11 06:36:18 CST; 2h 4min ago
       Docs: https://www.klipper3d.org/
   Main PID: 814 (python)
      Tasks: 2 (limit: 1472)
        CPU: 36.829s
     CGroup: /system.slice/klipper.service
             └─814 /home/pi/klippy-env/bin/python /home/pi/klipper/klippy/klippy.py /home/pi/printer_data/config/printer.cfg -I /home/pi/printer_data>


Link to comment
Share on other sites

@bmorgan99 I know you only posted yesterday but have you got anywhere with this?


I just finished getting mine setup today and the klipper firmware has installed OK as it renamed to firmware.cur but I cannot connect to it as running command below gives me nothing 😞

I feel maybe something is wrong or missing with the make menuconfig settings that are published??

pi@octopi:~ $ ls /dev/serial/by-id/
ls: cannot access '/dev/serial/by-id/': No such file or directory


Edited by Kris Wragg
Link to comment
Share on other sites

On 3/12/2023 at 4:40 PM, bmorgan99 said:

I've tried everything I can think of to no avail.  My thought is also menuconfig settings, but have found no others on the net so far.

This guy got it working so I posted our issue there

I too have tried pretty much everything I can think of and not got anywhere, raised a ticket to see what they say.

Things I have tried:

  1. Power board via USB instead of 24v DC by adding jumper to VUSB
  2. Try all 4 USB ports on Raspberry Pi 4B
  3. Try 3x USB cables
  4. Update klipper to latest (was about a month behind before) and recompile firmware
  5. Update Raspberry Pi OS to latest
  6. Run command 'dmesg' - nothing new found
  7. Run command 'lsusb' - nothing new found


Link to comment
Share on other sites

6 hours ago, bmorgan99 said:

This board is advertised as a "drop-in replacement".  Hope the maker checks these posts... or their github.

I am getting the distinct feeling this board only works when tied with a CM4/CB1 add-on board, but this is really not documented anywhere that it is the case and is clearly made to be an optional thing.

If that is the case then it's clearly not as advertised as everything leads you to believe that it should work via the micro-USB port like a standard Ender 3 board and that the use of a CM4/CB1 is purely optional.

I have tried several other things now as documented on the github page, including trying to get connection via UART on the TFT pins PD8 / PD9 but still no joy. I've raised a dispute with PayPal to get a refund as this board is either defective or totally not as advertised IMO.


  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 1 month later...

thanks a lot Billsef 😉. I bought recently a few of these boards to upgrade a few core xy I have and indeed all of them had the H743 cpu except one that had the other cpu H723. I didnt't realize this was a possibility and tried different thinks (changing usb cables, different usb ports in the Pi...etc) was already thinking of getting into contact for a replacement thinking it was a faulty board and I found your comment here and then I went to the official SKR E3 EZ biqu site and there it also  tells that it can come with two different cpus and in the physical box itself it is also specified so everyhting is working correctly now.



  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...