Jump to content

Hermit Crab CAN issues


Recommended Posts

Hello,

I'm currently working on setting up the Hermit Crab Can Edition with a BTT Octopus v1.1 and Raspberry PI 3B+. I have completed the wiring and have started to try to configure Klipper. I currently have Mainsail installed and it is recognizing my octopus board.

I am trying to get my raspberry pi to recognize the CAN-HotMode board. I have followed the steps on the github and have flashed the new firmware to the board. When I get to the step of running dmesg | grep -i '\(can\|spi\)', I am not getting the expected output. I am only getting:

[   97.663614] can: controller area network core
[   97.674453] can: raw protocol

It is not showing MCP2515 successfully initialized. Additionally, when I run "~/klippy-env/bin/python ~/klipper/scripts/canbus_query.py can0" it is showing "no such device".

I am at a loss and have tried flashing klipper firmware to the CAN-Hotmode board twice now, once with windows and again with the raspberry pi. Any help would be greatly appreciated.

Jon

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...