Jump to content

Manta E3EZ Canbus Woes

Recommended Posts

Hello friends, I cross posted this on reddit, but wanted to put it here for potential help.

Looking for some clear steps on getting canbus working on my manta e3ez and hoping the community can get back on track since I'm struggling to get anything going.

Short problem is that I can't get a can interface to come up. Steps are as follows:

  • Flash cb1 os to SD card, boot board

  • Update os and reboot for good measure

  • clone katapult to home directory and make with the following configuration(have tried both PD12/PD13 AND PB12/PB13)

  • cd to klipper directory, git pull and make with the following configuration(only tried using PB12/PB13)

  • Create interface file for can0

biqu@meow:~/katapult$ cat /etc/network/interfaces
source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto lo
iface lo inet loopback
auto can0
iface can0 inet manual
pre-up /sbin/ip link set can0 type can bitrate 1000000
up /sbin/ifconfig can0 up
down /sbin/ifconfig can0 down
  • Enter dfu mode with a two button tango and execute the following command, followed by a reboot...for good measure:

 sudo dfu-util -a 0 -D ~/katapult/out/katapult.bin --dfuse-address 0x08000000:force:mass-erase -d 0483:df11 && sudo dfu-util -a 0 -d 0483:df11 --dfuse-address 0x08002000:force:leave -D ~/klipper/out/klipper.bin
  • Upon rebooting, running ip link doesn't show a can0 adapter, and as expected trying ifup can0 fails because the interface isn't found.

My assumption is that after all of the above, that running lsusb would show a can device similar to this video: https://youtu.be/GfUMAPoJlR4?si=FW824EET4KXz4Ks4&t=582

Not sure where I'm going wrong. I've tried a few different things, but once I flash the device with katapult, my serial device drops so I feel like "it's working", but I never have a can0 interface. Currently, I have a hermit crab v2 that has been flashed with katapult via USB that is plugged into pb12/pb13 and powered...but I can't flash klipper to it since my can network isn't established. Thanks for any and all help. I'm sure I'm simply missing something.

Link to comment
Share on other sites

Just wanting to close the loop here to say that I support has helped me in a long running email chain we had going. The issue was related to my build for klipper and the communication. I was selecting the can pins directly but I instead needed to select the USB to CAN bus bridge and then select the appropriate can pins. I wasn't using the u2c device so I didn't think I needed that interface. Regardless, as soon as I did this my can interface came up!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...