Jump to content

BTT SKR Pico fail on flash

Recommended Posts

I am installing a Pico in an Ender 5 Pro. I have OctoPrint running, and according to Kiauh both Klipper and Octoprint are installed. The flash step seemed to fail, fairly late in the sequence, and so no /tmp/printer is created. It seems like this is a way to determine if flashing worked, maybe?

As far as I can tell, the firmware on the Pico is installed: BTT's Github directions say "the computer will re-identify the USB flash drive, means the firmware update is complete", which did not happen, but it did change the filename, which is what I've seen in prior efforts. [As an aside, these kinds of sloppy directions are really excruciating for someone who has never successfully installed Klipper to a motherboard, and BTT's directions constantly leave things out and skip over steps.]

Anyway, I think the firmware installation worked, b/c when I plugged it back in to the rpi, I got a USB port that showed up in the ls /dev/serial/by-id.

I created the printer.cfg from the recommended SKR Pico klipper.cfg, after adding the printer-specific serial port info (ls /dev/serial/by-id/). There are no comments at the top of this file, so I'm not sure if I need to change anything else: if I could just get this running I think I could clean it up later, no? I commented out a line in the mcu section concerning serial: /dev/ttyAMA0

When I run the "make flash FLASH..." command, I change it over to rp2040... there's not much more help. I can never connect to the printer in OctoPrint, I think that's because the /tmp/printer was never created, or at least that's some indication of where the problem is.

I think maybe I'm supposed to move klipper/out/klipper.bin somewhere, but I see no helpful reference to it or /tmp/printer in Klipper documentation, I just seem to remember something about that.

I'm not clear what to do, and I've gotten pretty overwhelmed and might be making obvious mistakes. BTW, I would pay someone to get me from here to my first print in Klipper, this process has been very costly to me. Message me if interested. Needs to happen soon though


Link to comment
Share on other sites

Posted (edited)

Well, I've gotten too far behind in my work, so I'm returning my Ender 5 pro to it's original motherboard, tuning it up and I'll try to get caught up on work. I'm also ordering a Voron kit: once I have it set up then I can take my time getting all this done, and it won't be so stressful.

I have to say, the BTT instructions are pretty frustrating. For example, they'll say plug the MB into the "computer", by which they mean the Windows or whatever machine, and then a few steps later it will be clear you had to plug it back into the rpi somewhere, but they didn't say when. If I was experienced with Klipper it would be different (and/or better with linux/raspbian), but it was quite frustrating. I wish that they provided a more methodical walkthrough of the steps, including tests at every possible point to confirm the last step succeeded: for a newbie, things can go wrong (like "make flash" breaking with an obscure error message) that can be hard to notice, and then break other things. 


Edited by Keith Winston
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...