Jump to content

New BTT SKR Mini 3/3.0 in an Ender 3. Red blinking light on power up?


docspace
 Share

Recommended Posts

I just received my SKR Mini E3 v3.0 this week and installed it in my Ender 3 v2 with BLTouch last night. I chose the kit with the modified cable for the stock Ender screen.

I started the machine up with the SD card inserted and it didn't appear to take the firmware (no .CUR). I reformatted the card and tried again, and now I have the firmware.CUR file on the card. This tells me that apparently the board is receiving power and able to install firmware.

However, I still have a constant red light and a blinking red light right next to it. The fans don't seem to spin up and the display doesn't change.

I have tried to start it up with the BLTouch removed, with the display removed and both removed.

Can you please help me out?

 

Thanks

ispacer.png

 

spacer.png

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...