Jump to content

SKR Mini E3 V3.0 does not respond to USB when Klipper firmware is flashed

Recommended Posts

Greetings! I have a BTT SKR E3 mini V3.0 and a Raspberry Pi 3B with a fresh install of octopi. I have built the firmware with the menuconfig options that BTT says I'm supposed to use, and I have also tried the pre-compiled binary from BTT's Github, and I get the same result:

They flash from the SD card just fine. The file "firmware.bin" is renamed to "FIRMWARE.CUR" after power cycling. But once the Klipper firmware is flashed, the pi will not see the serial port, and I get a solid red LED and nothing else. After all combinations of rebooting, replacing cables, etc. But if I then flash the precompiled Marlin firmware, the serial port pops right up with ls -l /dev/serial/by-id, and LEDs flash with activity.

So it seems like the flashing process is working fine. The USB cable is working fine. What's not working is the Klipper firmware as configured on the SKR Mini E3 V3 motherboard as configured.

Has something changed on the board that would change the configuration? Is there something wrong with the board?

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...