Jump to content

SKR mini E3 V3 with BL touch 3.1


Plungislua
 Share

Recommended Posts

Hello everyone, I have an Ender 5+ with firmware from Kersey Fabrications (Marlin 2.0.9.3) for the SKR E3 V3, and a BL touch smart 3.1. I am new to making firmware, but fairly comfortable with going in and changing out code to customize it.

I am having a strange issue where the BL touch works flawlessly 19 times out of 20, but then randomly it deploys.. the bed raises, and the probe just stays red and the bed crashes into the nozzle.

So far I have done:

  •   Verified my wires were connected to the correct pin (3 times), i use the Method where 3x are plugged into the sensor (brown red yellow) and 2x are in the z-end stop (black white)
  •   Double checked and redone the connector to the board incase bad connection.
  •   purchased a new BL touch, seems to do it less... but happened the first time I tried to do an auto level.

I am not sure if there is some line of code in marlin i missed/shouldnt of included or if i just need to replace the entire set of cables all the way from the board to the printer head. Any thoughts on this?

Link to comment
Share on other sites

So i have tried 2x BL touches, 1 is new out of the box (Purchased it from your amazon page).  they are both v3.1 bl touches. Both have the same issue.

I compared it to my other printer where the BL touch is working correctly, and it does the same colors at the same times.

it is red light on when stowed, deploys and turns blue. 

to be specific on what is happening, is about every 20th z probe it deploys like normal, then the bed moves up and makes contact with the probe. After about 1 mm or so the BL touch goes red but the probe doesn't stow, and it just keeps going till it crashes into the bed. 

 

it is only occasionally that it happens, but i get really nervous now every time it goes to home the Z-axis.  I have tried reflashing the firmware with the BL touch having all 5 wires go to the Z-probe connector and it does the same thing.... 

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for the late response, I ended up taking the SKR E3 V3 board our of my ender 5+ and put it inside an ender 3 pro. used the firmware on your website, works fine with this firmware. although the stepper driver started making a weird vibration noise when the X&Y axis both move at the same time.

the funny thing is that I put a SKR E3 V2 in my ender 5+ with the exact same configuration settings for probes/bltouch, and it works perfectly.  so I don't know what is wrong with the Marlin + Ender 5plus + SKR E3V3 combination, but something was causing the trigger inside the BLtouch to periodically not work or be registered by the board/firmware. 

I attached the 2x configuration files I initially had. it failed maybe once every 30 probes with this setup. NOTE These configuration files were originally pulled from your GITHUB site a few months ago (around December/January timeframe) and all I did was update parameters for it to work on an ender 5+

Configuration.h Configuration_adv.h

Edited by Plungislua
Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...