Jump to content

Mini E3 V3 firmware not loading and ST-Link V2 doesn't recognize board


Recommended Posts

I can connect to my old E3 V1.2 board and upload bootloaders and firmwares just fine. I've named the files firmware.bin and firmware. I have reformatted the SD card to FAT32. Still nothing. No FIRMWARE.CUR

I'm passed the 30 day window for Amazon return by 3 days!

Screenshot (34).png

Screenshot (35).png

Link to comment
Share on other sites

Hi,

Please check 

1. The motherboard does not need to brush the bootloader
2. Update the firmware
1. Name the same firmware as two different names; one named "firmware" and one named "firmware.bin"
2. Put the firmware of two names on the SD card and insert it into the card slot of the motherboard, and finally turn on the power, the motherboard will automatically refresh the firmware
3. After the refresh is completed, see which file name in the SD card becomes uppercase, indicating that the firmware refresh is successful.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...